A4988 Isınma Sorunu ve Nema 17 ..

Konusu 'Cnc & Torna' forumundadır ve uğur şirin tarafından 12 Şubat 2018 başlatılmıştır.


  1. uğur şirin

    uğur şirin Üye

    Katılım:
    17 Nisan 2017
    Mesajlar:
    13
    Beğenilen Mesajları:
    2
    Ödül Puanları:
    3
    Selamün aleyküm beyler Mega2560 + Ramps1.4 + A4988 ve Nema 17 ile MPCNC yaptım.
    3d cnc ramps elektrik verildiği zaman bir süre sonra motorlardan tık tık tık tık ses geliyor ve A4988'ler müthiş ısınıyor.. Isınmadan önce çok güzel çalışıyor. Ancak ısındıktan sonra 10mm hareket komutu gönderince eksik ya da hiç hareket etmeme durumu oluyor. Elektriği açınca ilk 30 saniye içinde A4988 ısınıyor ve herşey çok güzel çalışırken bir anda Nema17'lerden tık tık tık tık sesler gelmeye başlayınca motorlardan bu arıza sebebiyle Smart Graphic Controller'dan yolladığım bilgi kadar ilerleme yapmadan hata oluşuyor. Mesela A4988 ısınmadan önce 10mm giderken ısındıktan sonra ya eksik gidiyor ya da gitmiyor. Tık Tık Tık sesleri devam ederken " Motorları Sıfırla" dediğimde ses kesiliyor. Tekrar hareket ettiriyorum, gayet güzel gidiyor ama ilk hareketten sonra yine tık tık tık sesler gelmeye başlıyor motorlar hiç susmuyor. Bunun sebebi ne olabilir ? Çözümü nasıl aramalıyım?
     
  2. uğur şirin

    uğur şirin Üye

    Katılım:
    17 Nisan 2017
    Mesajlar:
    13
    Beğenilen Mesajları:
    2
    Ödül Puanları:
    3
    Yok mu üstadlar hiç yorum?
     
  3. Yusuf&CNC

    Yusuf&CNC Usta Üye

    Katılım:
    14 Ağustos 2015
    Mesajlar:
    1.446
    Beğenilen Mesajları:
    831
    Ödül Puanları:
    183
    Cinsiyet:
    Bay
    Meslek:
    Emekli
    Bulunduğu Yer:
    İstanbul
    Güle güle kullanın, umarım sorunlar kısa sürede çözülür.

    * Soğutma için mini alüminyum soğutucular var, sürücü entegresinin üzerine uygun şekilde (ısı tranferi sağlayacak) yapıştırdınız mı?
    * Küçük bir fanla soğutmaya yardımcı olabilirsiniz.
    * Sürücü üzerinden amper ayarı yaptınız mı? Sürücünün (dolayısı ile motorun) kullandığı amperi azaltarak ısınmayı azaltabilirsiniz karşılığında motorun torkunda azalma olacaktır.

    https://www.kontrolkalemi.com/forum/posts/660540/

    * DRV8825 sürücünün maks. amper değeri biraz daha yüksek, gerekirse değiştirilebilir. Motorunuzun amperi ne kadar?
     
    Son düzenleme: 13 Şubat 2018
  4. uğur şirin

    uğur şirin Üye

    Katılım:
    17 Nisan 2017
    Mesajlar:
    13
    Beğenilen Mesajları:
    2
    Ödül Puanları:
    3

    Sayın Yusuf&CNC ilginiz ve cevabınız için çok teşekkür ederim. Çok yardımcı oldu.

    *Soğutma için mini aluminyum soğutucu geldi ve ben de yapıştırdım.
    *Küçük bir fan aldım ancak daha denemedim.
    Sürücü üzerinden amper ayarının nasıl yapıldığını sizin yolladığınız videoyu görmeden bilmiyordum. Bu akşam onu denerim. Sonucu burada size paylaşırım.
    Benim kafamı karıştıran daha çok ısındığı anda bozuk adımlar atması. Korkuyorum acaba kartlardan birisi mi bozuk.. Çünkü ısınmadan ilk açtığımda çok güzel iken ısındığı anda adımları uyumsuz atıyor. Adımlar bozulduğunda ise motorlardan "tık tık tık tık" sesler geliyor ve trafodan gelen ses gibi kalıcı ve devamlı ses geliyor. Ben Ramps (marlin) üzerinden motorları durdur komutu gönderdiğimde bu ses susuyor. Tekrar ilk hareket komutuyla bu ses yeniden başlıyor. Sizce soğutma yaptığımda bu problem düzelir mi ?
     
    Yusuf&CNC bunu beğendi.
  5. akg

    akg Katılımcı Üye

    Katılım:
    21 Kasım 2014
    Mesajlar:
    462
    Beğenilen Mesajları:
    384
    Ödül Puanları:
    58
    Cinsiyet:
    Bay
    arduinoda firmware ne kullanıyorsun marlin mi yoksa grbl mi grbl kullanıyoprsan rampsin pinleri ile grbl nin pinlerinde farklılık var rampsa uyumlu düzenlemler yapmalısın yada hazır yapılmış düzenlemeler var onları kullanabilirsin. sürücü ısındığında anormal hereket etmesi normal. sürücüleri ters bağlamışsan arduinu üzerindeki regülatöre zarar vermiş olabilir regulatör ısınıncada bazen duraksamalar yapabilir.
     
  6. Yusuf&CNC

    Yusuf&CNC Usta Üye

    Katılım:
    14 Ağustos 2015
    Mesajlar:
    1.446
    Beğenilen Mesajları:
    831
    Ödül Puanları:
    183
    Cinsiyet:
    Bay
    Meslek:
    Emekli
    Bulunduğu Yer:
    İstanbul
    Çözülmeyebilir, sorunun çok farklı nedenleri olabilir. Örneğin bir kablodaki temassızlık gibi.

    Güç kaynağınızın amper çıkışı, motorlarınızın toplam amper gereksinimini karşılıyor mu? Elektrikteki dalgalanmaları da göz önüne alınca, çıkışın %30 kadar fazla olması öneriliyor.
     
    Son düzenleme: 13 Şubat 2018
  7. uğur şirin

    uğur şirin Üye

    Katılım:
    17 Nisan 2017
    Mesajlar:
    13
    Beğenilen Mesajları:
    2
    Ödül Puanları:
    3
    Sayın akg çok teşekkür ederim. Marlin kullanıyorum. sürücüler düzgün takıldı. Ayakları karşılaştırarak taktım ve özenle kontrol ettim.

    Kabloları kontrol edeceğim.

    Yorumunuza çok üzüldüm. Umarım kablo problemidir. Akşam deneyeceğim. Açıkçası kablolardan olacağını zannetmiyorum. Çünkü fabrikadan gelen kabloları kullandım ve ek-yama yapmadım. Umarım çaresini bulurum..

    Dün gece yabancı bir forumda "eozturk" kullanıcı adı ile aynı sorunu paylaşan ve birebir hatayı yaşayan başka bir kullanıcının birkaç gün sonra sorunumuz düzeldi dediği yorumu okudum. Orada potansiyometreden yapılan ayardan bahsetmiş. Umarım benim de sorunum potansiyometreden kaynaklanan sorundur.
     
    Yönetici tarafından son düzenleme: 13 Şubat 2018
  8. Yusuf&CNC

    Yusuf&CNC Usta Üye

    Katılım:
    14 Ağustos 2015
    Mesajlar:
    1.446
    Beğenilen Mesajları:
    831
    Ödül Puanları:
    183
    Cinsiyet:
    Bay
    Meslek:
    Emekli
    Bulunduğu Yer:
    İstanbul
    Son mesajıma bir ek yapmıştım.

    Önce tek bir motoru denemek işinizi kolaylaştırabilir.
    Motoru, kabloyu, sürücüyü değiştirerek tekini çalıştırmayı deneyin. Denemeler sırasında arıza olasılığı da azalır. Sürücülerin yönüne de dikkat etmek gerekiyor, ters de takılabiliyor, cihazların bozulmasına yol açabilir. Elektrik varken sürücü ve motor kablolarının sökülüp takılması da bozulmasına neden olabilir.

    Yeniden almanız gerekirse DRV8825 sürücüler A4988'den daha iyi. Aklımda kalan DRV8825 takılırken yönünün A4988 ile farklı göründüğü, şaşırtmasın.

    Not:
    Kullanıcı adlarının başına @ işareti de koyarsanız, o kişiye mesajda etiketlendiniz bilgisi gider
     
    Son düzenleme: 13 Şubat 2018
  9. togitogi

    togitogi Profesyonel Üye

    Katılım:
    13 Mart 2009
    Mesajlar:
    1.458
    Beğenilen Mesajları:
    1.196
    Ödül Puanları:
    523
    Cinsiyet:
    Bay
    Meslek:
    Elektrik Teknikeri
    Bulunduğu Yer:
    İZMİR
    Potansiyometreden yapılan ayar:Step motor akım ayarıdır.
    A4988 yerine Drv8825 daha fazla çözünürlük daha fazla akım vb..
     
  10. uğur şirin

    uğur şirin Üye

    Katılım:
    17 Nisan 2017
    Mesajlar:
    13
    Beğenilen Mesajları:
    2
    Ödül Puanları:
    3
    Sorunu canlı olarak gösteren ufak bir video attım. Bakmak ve belki detaydan hatayı fark edebilirseniz çok sevinirim..

    http://youtube.be/kPMjWOCIXVs

    videoda tam göstermemiş ama ilk hareket komutunda çok güzel hareket ediyor. tık tık tık sesler başladığı anda arıza başlıyor..
     
Yüklüyor...
Benzer Konular
  1. huh
    Mesaj:
    16
    Görüntüleme:
    525
  2. bunyamin01
    Mesaj:
    0
    Görüntüleme:
    127
  3. CKR90
    Mesaj:
    7
    Görüntüleme:
    531
  4. nanit
    Mesaj:
    3
    Görüntüleme:
    284
  5. ankis
    Mesaj:
    12
    Görüntüleme:
    916
  6. ankis
    Mesaj:
    2
    Görüntüleme:
    382
  7. İbrahim N.
    Mesaj:
    6
    Görüntüleme:
    616
  8. Suat_Korkmaz
    Mesaj:
    37
    Görüntüleme:
    2.277
  9. togitogi
    Mesaj:
    38
    Görüntüleme:
    6.360
  10. tecevit
    Mesaj:
    3
    Görüntüleme:
    1.265

Sayfayı Paylaş