Sinamic G120C NPN ve S7 300 315 DP arasındaki bağlantı ve programı

Katılım
30 Eyl 2014
Mesajlar
110
Puanları
3
Yaş
37
Merhaba,G120c PN sürücüyü s7 300 DP ile sürmek istedim. PLC'de profinet portu olmadığı için CP343-1 Lean ethernet kullandım. Profinet üzerinden G120C ile CP343'ü bağladım.( ek : PLC ile sürücü profinet) Ancak bu şekilde bağlantı da ekte verdiğim konfigürasyon dosyasında göründüğü gibi sürücünün communication ayarlarında herhangi bir I/O adresi tanımlamadı.(Ek: konfigürasyon) sadece CP343'ün altında I/O adresi olarak 256-271 arası adresler verdi. (ek: CP343)
Program kısmında ise bu adresleri kullanarak yazdım. Stop için 047e-->PQW256'ya ,hareket için 047f-->PQW256'ya, geri için 0c7e -->PQW258'e gönderdim. Ancak bir türlü sürücüyü sürmeyi başaramadım. Tiaportal V15 kullanıyorum ve sürücüyü buradan commisioning--> altındaki control panelinden kullanabiliyorum ancak yazılım ile bir türlü programlayarak süremedim. Bütün telegramları da denedim yine de olmadı.Sizden yardım istiyorum.Şimdiden çok teşekkür ederim.
 

Ekli dosyalar

as.yıldırım

Paylaşımcı üye
Katılım
14 Eki 2011
Mesajlar
1,055
Puanları
108
PLC ile sürücü profinet isimli fotoya baktığımızda sürücüde "not assigned" yazıyor. Yani PLC ile sürücü eşleşmemiş. Onu düzeltmeniz gerekiyor.

Yazılım tarafından seçtiğiniz telegram tipini sürücü parametrelerinden de ayarlamalısınız.

yanlış hatırlamıyorsam p922 nolu parametreydi.

Bu bahsettiklerimi inceleyebilir misiniz ?
 
Konu Sah
S
Katılım
30 Eyl 2014
Mesajlar
110
Puanları
3
Yaş
37
as-yıldırım bey merhaba,dediklerinizi yaptım ama not assign hk.da
PLC ile sürücü profinet isimli fotoya baktığımızda sürücüde "not assigned" yazıyor. Yani PLC ile sürücü eşleşmemiş. Onu düzeltmeniz gerekiyor.

Yazılım tarafından seçtiğiniz telegram tipini sürücü parametrelerinden de ayarlamalısınız.

yanlış hatırlamıyorsam p922 nolu parametreydi.

Bu bahsettiklerimi inceleyebilir misiniz ?

As.yıldırım merhaba,dediklerinizi yaptım ama not assign'i nasıl düzeltebilirim? daha önce de denedim ama bulamadım.
 

as.yıldırım

Paylaşımcı üye
Katılım
14 Eki 2011
Mesajlar
1,055
Puanları
108
"not assigned" üzerine sol ve ya sağ tıkayıp tıklayıp profinet bağlantısını seçin.
 
Konu Sah
S
Katılım
30 Eyl 2014
Mesajlar
110
Puanları
3
Yaş
37
assign
"not assigned" üzerine sol ve ya sağ tıkayıp tıklayıp profinet bağlantısını seçin.
not assign sağ tıklattığımda "selectIO controller"--> hiçbir şey yapılamıyor(ek: not assign), zaten profinet üzerinden PLC ye bağlı, sol tıklattığımda da show katalog--> katalogtan (ek: not assign1) controller seçtiğimde de çıkıyor. PLC2 ekliyor.(not assign2). Yani etkilemedi hocam ne yazıkki.
 

Ekli dosyalar

as.yıldırım

Paylaşımcı üye
Katılım
14 Eki 2011
Mesajlar
1,055
Puanları
108
direk PN olan bir PLC de dediğim şey oluyor ama DP ye PN modülü eklediğimizde olmuyor.ben de şimdi denedim ve gördüm.

İlla ki bir yöntemi vardır , bence Siemens i arayıp bir sorun.

Hatta cevabı paylaşırsanız biz de öğrenmiş oluruz.
 
Konu Sah
S
Katılım
30 Eyl 2014
Mesajlar
110
Puanları
3
Yaş
37
merhaba,
Sorunu çözdüm. Problem profinet kartı olarak kullandığımız CP343 Lean ethernet kart sadece PC'ye bağlanmak için kullanılıyormuş. Bu kart ile motor sürücü vs bağlantısı kurulamıyor. Bu nedenle yeni profinet destekli başka bir kart siparişi verdik. Yardım eden arkadaşlara teşekkür ederim.
 

Sponsor Bağlantı

Forum istatistikleri

Konular
106,470
Mesajlar
750,348
Kullanıcılar
395,723
Son üye
cgdsny

Yeni konular

Üst