Raspberry Pi Step Motor kontrolü

muhosevo

Üye
Katılım
13 Tem 2020
Mesajlar
7
Puanları
1
Yaş
21
Herkese merhaba, elimde raspberry pi 4 bilgisayarım var, Nema34 step motor sürmek istiyorum. Fakat bir türlü pulse üretemedim ya da ürettim ama bunu motora aktaramıyorum. Kodu yazıp ilgili pine dokunduğumda motor anlık olarak hareket ediyor, sonra duruyor. Benim sürekli pine dokunup çekmem gerek anca öyle dönüyor. Yazmış olduğum kodlar:

import pigpio
from time import sleep

pi = pigpio.pi()
pin = 21

pi.set_mode(pin, pigpi.oUTPUT)
while True:
pi.write(pin, 1)
sleep(0.1)
pi.write(pin, 0)
sleep(0.1)



bu scripti çalıştırınca dediğim gibi motor sadece anlık olarak tık diye bir seferliğine hareket ediyor, sonra duruyor.
Motor sürücüm CWD860. Nema34 Step motor. sürücü 5v çıkış veriyor. Raspberry pi pinleri ise 3.3 volt çıkış veriyor. Bununla alakalı bir sorun olabilir mi bilmiyorum. Yardımcı olursanız çok sevinirim, Herkese teşekkürler.
 
Son düzenleme:

mehmet.bey

Usta Üye
Katılım
19 Ara 2011
Mesajlar
1,343
Puanları
183
"while True:" satırı altında tab var mı?
 

alarmko

Üye
Katılım
14 Ocak 2009
Mesajlar
598
Puanları
33
Bak kardeş,öncelikle kodunu kontrol et.Phyton dilinde soldaki boşlugun anlamı var.Eger yazdıgınız kod burda gözüktügü şekilde ise zaten çalışmaz.öncelikle çıkışına bir tane led bagla yakıp söndürmeye çalış.Eger becerirsen sonra bu çıkışı sürücüye baglarsın.Youtubeyi ac,nasıl led yakıp söndürmüşler ögren,sonrada motorunu çalıştır.
 
Konu Sah
muhosevo

muhosevo

Üye
Katılım
13 Tem 2020
Mesajlar
7
Puanları
1
Yaş
21
"while True:" satırı altında tab var mı?
tabiki de var, burda öyle çıkmış.
Bak kardeş,öncelikle kodunu kontrol et.Phyton dilinde soldaki boşlugun anlamı var.Eger yazdıgınız kod burda gözüktügü şekilde ise zaten çalışmaz.öncelikle çıkışına bir tane led bagla yakıp söndürmeye çalış.Eger becerirsen sonra bu çıkışı sürücüye baglarsın.Youtubeyi ac,nasıl led yakıp söndürmüşler ögren,sonrada motorunu çalıştır.
led yakmayı zaten yaptım, aynı şeyleri yapmama rağmen motor dönmüyor, kodda herhangi bir problem yok aynı şekilde motorda da bir problem olmadığını ve bağlantıların doğru olduğunu söylüyorlar.
 

Yeni mesajlar

Forum istatistikleri

Konular
115,530
Mesajlar
813,616
Kullanıcılar
422,135
Son üye
radyokanallari

Yeni konular

Üst