Y ekseni Slave eksen Sorunu

ankis

Katılımcı Üye
Katılım
15 Nis 2011
Mesajlar
364
Puanları
56
Merhaba arkadaşlar, Onca tecrübeme rağmen benimde çözüm aradığım konuların başında kesim hassasiyeti geliyor. Bu yüzden kesimde hassasiyeti bozan eksenime 2. bir motor eklemek istedim. Y ekseni üzerinde kullandığım 3nm torklu 3 fazlı ana motorumu bir yana ve simetrisine 2nm torklu 3 fazlı aynı marka motoru ekledim. Ayarlarda gerekli değişiklikleri yaptım dönüş yönlerini falan düzelttim. JOG mod da 1 mm git dediğinde 2 motor da gayet güzel çalışıyor ama jog dan çıkıp klavyeden sürekli hareket ile hareket ettirdiğimde slave olan motor devamlı hareket ediyor elimi klavyeden çektiğim halde durmuyor. Kontrol kartı N motion diye 6 eksen li bir kart.
Slave eksen g code uygulamasında düzgün çalışıyor ama olası bir durumda es kaza JOG MOD dışında klavyeden hareket verirsem makinanın köprüsü darmadağın olacak. sorun hakkında önerisi olan varmı ?
 

Yusuf SEYLAN

Usta Üye
Katılım
3 Ocak 2015
Mesajlar
1,225
Puanları
181
Merhaba arkadaşlar, Onca tecrübeme rağmen benimde çözüm aradığım konuların başında kesim hassasiyeti geliyor. Bu yüzden kesimde hassasiyeti bozan eksenime 2. bir motor eklemek istedim. Y ekseni üzerinde kullandığım 3nm torklu 3 fazlı ana motorumu bir yana ve simetrisine 2nm torklu 3 fazlı aynı marka motoru ekledim. Ayarlarda gerekli değişiklikleri yaptım dönüş yönlerini falan düzelttim. JOG mod da 1 mm git dediğinde 2 motor da gayet güzel çalışıyor ama jog dan çıkıp klavyeden sürekli hareket ile hareket ettirdiğimde slave olan motor devamlı hareket ediyor elimi klavyeden çektiğim halde durmuyor. Kontrol kartı N motion diye 6 eksen li bir kart.
Slave eksen g code uygulamasında düzgün çalışıyor ama olası bir durumda es kaza JOG MOD dışında klavyeden hareket verirsem makinanın köprüsü darmadağın olacak. sorun hakkında önerisi olan varmı ?
klavyeden hareket verirken feedrate düşürüp yapın durum düzelirse sorununuz slave motor adım kaçırıyordur
 
Konu Sah
ankis

ankis

Katılımcı Üye
Katılım
15 Nis 2011
Mesajlar
364
Puanları
56
klavyeden hareket verirken feedrate düşürüp yapın durum düzelirse sorununuz slave motor adım kaçırıyordur
:) JOG modda klavyeden hareket ettirildiğinde istenen mesafe de gidiyor zaten 1mm ise 1 mm ,0.01 mm ise 0.01 mm .... sorun jog dan çıkıp klavyeden belirsiz uzunlukda hareket ettirilmesinde... step motor jog dan çıkarıldığında hareketi sürekli yapıyor , klavyeden tersi yönde git dediğinde tersi yönde dönüyor ama durmuyor :) bildiğin dc motor gibi sürekli dönüyor... hani step motoru spindle gibi kullanabilirim diyecem ama nema 23 alt tarafı :)
 

KAYSERİ

Profesyonel Üye
Katılım
13 Ocak 2010
Mesajlar
2,920
Puanları
515
Yaş
30
Konum
Kayseri
abi sende benim gibi çok enteresan sorunlar yaşamaya başlamışsın. Bende akla hayale gelmedik sorunlarla uğraşıyordum sürekli. :D :D :D
 
Konu Sah
ankis

ankis

Katılımcı Üye
Katılım
15 Nis 2011
Mesajlar
364
Puanları
56
sen benim yaşadığım sorunları bilsen aklın başından uçar gider.Bunu samimi olarak söylüyorum, en akıl almaz en beklenmedik ne varsa uğramadan geçmez bizde.... ayağımı okyanusa soksam okyanus kurur....
 

alarmko

Katılımcı Üye
Katılım
14 Ocak 2009
Mesajlar
729
Puanları
56
Yaş
56
Bana bu sorun sanki klavye ile kontrol kartı arasındaki iletişimle alakalı gibi geliyor.Büyük ihtimalle kart pc den gelen tek bir komutu birden fazla algılıyor ve bir kere bir tuşa basmanıza ragmen birden çok basılmış gibi işlem yapıyor.
Kartın arayüzünden müdahale edilebilirmi bilmiyorum ancak sanki karta bir komut gönderildiginde yeni komutu kabul etmeden evvel hafızasını sıfırlamak gerekiyor.
Birbaşka çözüm yolu olarakta aklıma klavyelerin tuş hızları ile oynamak geliyor.mause ve klavye ayarlarından hızlarını azaltıp bir deneyiniz.
 
Konu Sah
ankis

ankis

Katılımcı Üye
Katılım
15 Nis 2011
Mesajlar
364
Puanları
56
Bana bu sorun sanki klavye ile kontrol kartı arasındaki iletişimle alakalı gibi geliyor.Büyük ihtimalle kart pc den gelen tek bir komutu birden fazla algılıyor ve bir kere bir tuşa basmanıza ragmen birden çok basılmış gibi işlem yapıyor.
Kartın arayüzünden müdahale edilebilirmi bilmiyorum ancak sanki karta bir komut gönderildiginde yeni komutu kabul etmeden evvel hafızasını sıfırlamak gerekiyor.
Birbaşka çözüm yolu olarakta aklıma klavyelerin tuş hızları ile oynamak geliyor.mause ve klavye ayarlarından hızlarını azaltıp bir deneyiniz.
dediğin bir parça olabilir diyorum ama olmama durumuda var, jog modda iken klavyeden 1 mm git dediğinde slave eksen gidiyor sorun yok ; ama jog dan çıkıp klavyeden yada mouse ile ok yön işaretleri ile git dediğinde belirsiz bi mesafe de oluyor... durmuyor , stop desende durmuyor, ancak reset e basman lazım .... bence sorun kontrol kartında ama bunu ben çözemeyecem beni aşıyor...slave olmayan eksenlerde bi sorun yok normal çalışıyorlar....
 

Yeni mesajlar

Forum istatistikleri

Konular
118,553
Mesajlar
834,652
Kullanıcılar
430,628
Son üye
Easlan01

Yeni konular

Üst