WinCC 5.1 den 6.2'ye Yükseltme (Migration) İşlemi yardım?

  • Konbuyu başlatan tecno_laz
  • Başlangıç tarihi

tecno_laz

Üye
Katılım
23 Nis 2008
Mesajlar
15
Puanları
1
Yaş
37
Merhabalar.
Çalıştığım işyerindeki Scada bilgisayarları çok eski ve hantal olduğu için yenileme ihtiyacı duyduk. 20 yıldır kullanılan artık ömrünü tüketmek üzere olan sistemleri daha performanslı hale getirmek için yükseltmemiz gerekiyor.

//----Mevcut Sistem--//

WinCC 5.1 de faal olarak

Windows NT 4.0 SP6

intel P3 işlemcili

3x256 mb Ramli

CP 1413 Endustriyel kart

3 adet bir biriye senkronize çalışan Scadamız var.

Mevcut Proje dosyaları D:\ klasöründe

WinCC kurulumu C:\Siemens altında bulunuyor.



//----YeniSistem--//

i7 3.2 Ghz

Windows 10

8 Gb Ram

1 Tb hdd



Pc de RS232 LPT ve PCI yuvası yok PCi Express yuvası ve PCiE x1 yuvası var. Fakat projeyi çalıştırabilirsek ihtiyaca göre temin edebiliriz.



Yine forumlarda araştırmama göre pci CP 5612 daha verimli çalıştığı için ve hem XP hem Win7 driver i bulunduğu için CP 1413 yerine bunu alıp kullanmayı düşünüyorum. CP kart için tavsiyede bulunursanız sevinirim.



PC de VirtualBox yardımı ile bu işlemleri sanal ortamda gerçekleştiriyorum(Şimdilik)


Araştırmalarıma göre WinCC projelerini üst sürümde açmak için adım adım yükseltip Migration yapmamız gerekiyor.


1- Öncelikle mevcut sürüm 5.1 olan WinCC yi 6.2 ye yükseltmekle başladım. Bunun için Bilgisayarıma Sanal XP 32 bit Professional SP3 (Türkçe) İşletim sistemi kurdum. (Usb To Serial RS 232 nin driverı , Misafir oturumunu bu sayede ekran kartını kurdum.) eksik driver görünmüyor.

2- Message Queen ve ISS yi aktif edip yeniden başlattım.

3- SQL_Server_2005_SP1_Standard kurulumunu eksiksiz yaptım.

4- WinCC_V6.2_SP3 kurulumunu benden istediği şekilde yerine getirerek kurulumu hatasız tamamladım.

Lisans işlemlerini bin\ klasörü içine kopyala yapıştır yaparak gerçekleştirdim.Faal olarak XP de WinCC V6.2 yi çalıştırdım proje oluşturma yapabildim. (lisans hatası almıyorum)// Lisans işlemini Automation License Manager ile mi yapamam gerekiyor ?(Lisans hatası almıyorum!!)



Daha sonra Siemens Migration v5 to v6 dökümanından adımları sırasıyla anladığım kadarıyla uygulamaya çalıştım.



//----Yapdığım işlemler sırasıyla.--//
5-Eski çalışan WinNT deki (daha önce D:\ sürücüsünün imajı alınmış olan ve kontrol ettim çalışıyor.) D:\ nin imajını Sanal XP nin D:\ sine attım.

6-WinCC_V6.2_SP3 içinde OPTINS klasorunda Sybase7 Setup ını başlattım. Benden WinCC 5.1 Cd mi istedi. WinCC V5.1 Control Center Cd sini takarak bu adımı hata almadan tamamladım. PC yeniden başlattım.

7-WinCC/Tools/Project Migrator ü başlatarak.(Görseline Siemens Migration dokumanından bakabilirsiniz)
-Select the project: // buraya eski bilgisayardan alınan D:\ klasöründe bulunan D:\Projem\Projem.MCP dosyası gösterildi.

-Pictures and Libraries //işaretlendi.
-Configration data // işaretlendi.

-RT data /işaretlendi

ilk bu şekilde ve daha sonra

//-----------------------------------------

Sonra bu şekilde

-dBase arsiche(s)

//-----------------------------------------


daha sonra bu şekilde

-Swapped-out data //işaretleyerek ve yine aynı klasör yolunu göstererek denedim. (D:\Projem\)



7.adımı yaparken convert vs işlemlerinde hata almadım. hepsi başarıyla tamamladın.



8-Masa üstünden SIMATIC WinCC Explorer ı Administrator olarak D:\Projem\Projem.MCP mi açtım ve projeyi yürüttüm.

Uygulamam Sql deki veritabanına bağlantı açıldı. Ana ekran geldi. Fakat Ana ekran geldikten sonra ufak bir Logon ekranı gelip şifre sorması gerekiyor. Ayrıca projedeki butonların üstünde yazanların yerinde TEXT yazıyor Aşağıdaki butonlar gelmiyor. En önemlisi Login olacağımız giriş ad ve şifremizi yazdığımız ufak pencere açılmıyor.(Eski projede yazıcılarda log kaydı tutuluyor LPT bağlantısı kesilince arıza veriyor. LPT olmadığından proje açılınca yazıcı bağlantısı yok uyarısı veriyor.Sağ üstte ufak bir saat var çalışıyor. Belli bir süre sonra en üstte Not Active yazısı çıkıyor. Hiç bir yere tıklanmıyor. etkin olmayan sayfa gibi.)



Ayrıca çalışan sistemde birde Chip Card sistemi var RS232 ile bağlı. Normalde proje açılır login ekranı gelir Şifremizi girer yada kartı takarız ve proje çalışmaya başlar.Fakat yeni kurulumda login sayfası gelmiyor bile.



Zaten eski bilgisayarda Chip Card RS232 ye takılı olmadan da o ekran geliyor. CP 1413 kart pc ye takılı olmadan da proje açılıyor fakat hata bağlantı hatası veriyor. // Biz bu adımları geçebilirsek ihtiyacımız olan kartları ve bilgisayarları ona göre temin edicez.



Chip Cart Terminal Eski Windows NT de kurulu fakat XP de kurulumunu yapamadım. (bundan olma ihtimali var mı ? proje eski sistemde kart olamadan şifreyle de çalışıyor.)

(RS232 COM1 için USB to RS232 kullandık)
Kısaca projem verimli çalışıp açılmıyor.





Öncelikle Sabırla okuduğunuz için teşekkür ederim.

Aklıma takılan cevabından net emin olmadığım soru ve sorunlarımı size sorayım.

1-Bu yazdığım adımlar dışında farklı bir işlem yapmadım. Sizce kurulumda migrasyonda bir hata yapmış olabilir miyim ?

2-XP Professional SP3 Türkçe kurulu İngilizce kurmam (veya başka bir Cd den kurmam) sorunumu çözer mi?

3-Yeni bilgisayara WinCC Chipcard Terminal uygulaması kurulu değil (Eski Pc de Control Panel de WinCC Chipcard Terminal uygulaması var) Xp de kurulumunu bulup yapamadım eski makinada açtığında Com port seçimi yapılıyor.

Eski sistemde Rs232 ye Chip Card terminal takılı olamadan da şifreyle giriş yapılıyor. Fakat uygulaması (WinCC Chipcard Terminal) kurulu olmadığı için yapabilir mİ?

4-Yeni bilgisayara CP kartı takıp tanıtmadığım için bu sorunu yaşamış olabilir miyim ?
Evet ise (eski çalışan sistemde kartı sökünce logon ekranının geldiği gözlemlendi.)

Kartı takacak Pci yuvam olmadığından kartı takmadan bu adımı geçebilir miyim ?

5-Donanımda RS232 LPT ve CP kart olmadan uygulama başlaması gerekmez mi ?
6-Sizce Nerede eksik yaptım ?

Edit: Eski sistemde proje başlarken programfiles/VST klasörü içinde başlattığı Siemensin Verkehrssteuerung V3.0 VSTStart diye bir kaç program var. Bunları eski sürümde pc den kaldırınca XP deki gibi açılış ekranında login ekranı gelmeden kalıyor. Sanırım VST içindeki uygulamaları kurmam lazım. Kopyala yapıştır yapıp Startup da başlatınca ocx tarzı run time error 429 hatası veriyor.


Yardımcı olursanız çok teşekkür ederim.


Not: PLC Scada sistemleri konusunda çok bilgi sahibi değilim. Asıl mesleğim Elektronik kart tamirleri vs. VB ,C# , C++ gibi dillere hakimim. Kendi işlerimi görecek kadar uygulama yazıyorum.
 
Son düzenleme:
KNX Standardı, küçük bir rezidansın içerisindeki aydınlatma, perde panjur, klima kontrolünden, Dünya’nın en büyük havalimanlarındaki aydınlatma otomasyonu gibi çözümler için tercih edilen bir Dünya standardıdır.
Yazımızda endüstrinin can damarı sayılabilecek PLC’yi inceleyeceğiz.
Konu Sah

tecno_laz

Üye
Katılım
23 Nis 2008
Mesajlar
15
Puanları
1
Yaş
37
Uzun uğraşlar ve denemeler sonrasında projeyi 5.1 den 6.2 ye geçişini yaptık şuan projemiz çalışıyor.
Sanalda xp işletim sisteminde çalıştırmak istiyorum cp 1613 ü nasıl sanal xp ye tanıtabilirim bilgisayarım windows 10 hazırda virtual box ile sanal xp kullanıyorum proje xp de fakat pci da takılı cp1613 kartı sanal xpye gösteremedim var mı yöntemi
 

canerland

Üye
Katılım
24 Eyl 2006
Mesajlar
507
Puanları
6
Sanal xp de donanım olarak gene de bilinmeyen aygıt olarak görmesi lazım. VMware Workstation sanal program ile bir deneyin. virtual box win10 da çok yetenekli çalışmıyor
 
Konu Sah

tecno_laz

Üye
Katılım
23 Nis 2008
Mesajlar
15
Puanları
1
Yaş
37
Sanal xp de donanım olarak gene de bilinmeyen aygıt olarak görmesi lazım. VMware Workstation sanal program ile bir deneyin. virtual box win10 da çok yetenekli çalışmıyor
Teşekkürler şimdilik yeni bir bilgisayara Xp kurarak CP1613 ü pci a takıp çalıştırdık.
Sırada 2 scada arasındaki ethernet bağlantısı kaldı. yani Scada 1 ve Scada2 diye iki adet projemiz var bu projelerin xp de wincc 5.1 den 6.2 ye migrasyonunu yapıp ağda bağladık. Ağ paylaşımını açtık dosyalar birbirini görüyor fakat scada kendi arasında haberleştiremedik. Wincc nin scadalar arasında haberleşmesi için özele Cominications Configtation diye birşey yüklendi sanırım bilgisi olan var mı ?
 
Konu Sah

tecno_laz

Üye
Katılım
23 Nis 2008
Mesajlar
15
Puanları
1
Yaş
37
Scadaları ağda (ethernet ile) birbiri arasında haberleştirdik.
Size şunu soracağım. v5.1 de Cp 1413 kullanıyorduk.
v6.2 de 1613 kullanmak istiyorum elimde birtane var.
1- İlk olarak CP 1413 XP ve wincc 6.2 ile uyumlumudur?
(araştırmama göre XP driver var ama 6.2 ile ikilemde kaldım)
2-V5.1 de Tag Management de S5 PMC Ethernet var 6.2 ye migrasyon yapınca burası kayboluyor. CP1613 için SIMATIC S7 yükleyip CP1613 tanıtıyorum devamında nasıl bir yol izlemeliyim. S5 PMC Ethernet yerine Cp1613 de ne kurmalıyım ?

Teşekkürler..
58977
6gk1901-0aa00-0aa0
58978
6gk1143-0ta02

5.1 deki projem 3tane Scada da Cp1413 ler ile bunlar ile birleşip PLC S5 155H ile haberleşiyor (6gk1143-0ta02)
Projemi Pro Xp 32 bit Wincc 6.2 sürümüne yükselttim hatasız çalışıyor.(lan bağlantıları görüyor)
-Cp1413 yerine -CP1613 var nasıl bir işlem yapmalıyım ki PLC ile bağlantı kurabileyim?
 
Son düzenleme:
Konu Sah

tecno_laz

Üye
Katılım
23 Nis 2008
Mesajlar
15
Puanları
1
Yaş
37
Araştırmalarıma göre 5.1 den 6.2 ye geçince SIMATIC S5 PMC Ethernet iletişim kanalı artık kullanılmıyor. tabi bizim projemizde de SIMATIC S5 PMC Ethernet kullanıldığından Tag Managment de not installed hatası veriyor. Kısaca SIMATIC S5 PMC Ethernet yerine v6.2 de cp1613 için ne kullanabiliriz.
 

upik

Üye
Katılım
21 Nis 2012
Mesajlar
18
Puanları
1
S5 PMC ethernet Layer i 6.2 ye kopyaladık migrasyonu tamamladık. Proje sorunsuz bir şekilde 6.2 ye geçiş yaptı düzenli olarak çalışıyor.
 

Forum istatistikleri

Konular
118,012
Mesajlar
831,890
Kullanıcılar
429,288
Son üye
hqn00

Yeni konular

Üst