WAGO 750-880 webvisu.htm JAVA sıkıntısı.

bbulutlu

Üye
Katılım
19 Mar 2010
Mesajlar
44
Puanları
3
Merhaba.

WAGO 750-880 PLC ile yerel ağ üzerinden uzaktan izleme projesi gerçekleştirmekteyim.

PLC düzgün olarak çalışıyor ancak browser(chrome) üzerinden webvisu.htm ye bağlanmaya çalıştığımda java yükleniyor resmi(kahve fincanı) çıktıktan sonra boş bir ekran ile karşılaşıyorum.

Firefox ile açtığımda köşede bir error yazısı, tıklandığında class bulunamadı yazısı çıkıyor.

Aşağıdaki linkten JAVA kullanmadan izleme sayfasını indirdim.
http://webvisu.sourceforge.net/

Bu sayfayı plc ye yükleyip açtığımda yazılar karman çorman olarak ta olsa yaptığım visualization sayfasını görebiliyorum.

Buradan yaptığım çıkarıma göre PLC den ziyade webvisu.htm ile java arasında bir uyuşmazlık mevcut.

Web visunun her bilgisayarda çalışmasını nasıl sağlayabilirim?

Benzer sorunla karşılaşan arkadaşlar konu ile ilgili yardımcı olabilirlerse sevinirim.

Şimdiden Teşekkürler.

İşletim sistemi windows 8.1
JAVA 1.8 build 25
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
dostum aynı problemden bende muzdaribim.Eğer çözümü bulup bizimlede paylaşırsan sevinirim.

bende araştırma içerisindeyim devamda ediyorum.Benim bulabildiğim bilgiler;

ocak14 de java güncellemeye gitmiş ve wago plclerinde içerisindeki .jar dosyalarının güncellenmesi gerekiyor.(ben denedim ama çözüm olmadı sende bir dene)
WagoUpload kullanımı videosu;

wago java güncelleme dosyaları ve açıklaması;

http://www.wago.us/products/components-for-automation/java-7-update/

ben buraya kadar gelebildim inş çözeriz..
 
Konu Sah
B

bbulutlu

Üye
Katılım
19 Mar 2010
Mesajlar
44
Puanları
3
http://sourceforge.net/projects/webvisu/ buradaki webwisu dosyasını indirip plc dekinin içindeki ile değiştirdim sorun çözülür gibi oldu. Yazılar felan tam istediğin gibi olmuyor. Nitekim çok fazla görsellik vermezsen çalışıyor.
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
bunada şükür :) bende denedim şimdi oldu sayılır.Burdan yola çıkarak webvisu.htm dosyasının java ile uyumsuzluğundan şüphelenebilirmiyiz acaba.?
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
bu arada şunuda farkettim.
Bilgisayarda http://*******/plc/webvisu.htm dosyası açılmıyor fakat akıllı telefonlar için app den indirilen wago webvisu programında açılıyor.

Senin linkte gönderdiğin dosyayı da attım plcye webvisu.html olarak bu seferde pc de çalıştı ama teldeki webvisu da çalışmadı.

wagoyada danıştım ama sanırım derdimi anlatamadım.Bana pc ye sanalpc kurmamı falan önerdiler :/ ????
 
Konu Sah
B

bbulutlu

Üye
Katılım
19 Mar 2010
Mesajlar
44
Puanları
3
Sorun java kütüphanelerini açmak için belirtilen adreslerin türkçe karakter desteklemiyor oluşu.
Özetle kütüphanenin bulunduğu yere ulaşamayınca açılmıyor.

İngilizce işletim sistemlerinde bu sorun yaşanmıyor. Aslında sorun sadece Wago ya özgü de değil sanırım.

Mevcut işletim sistemini değiştirmeden ingilizce bir işletim sistemi kurmanın yolu da sanal makineden geçiyor.

Vİrtual box bir çözüm olabilir ancak müşteriye önce web browser'ı olan her bilgisayardan görebilirsin deyip sonrasında abi ingilizce olması lazımmış, sanal makine lazımmış vs vs diyince sıkıntı oluyor.
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
Teşekkürler.
Wagoda bana böyle bişi sölemişti olamaz böle saçmalık deyip dikkate almamıştım. Demekki böyle bi saçmalık varmış.

Anlaşılan müşteriye madara olacağız :(
 

seagate

Profesyonel Üye
Katılım
27 Şub 2007
Mesajlar
1,786
Puanları
283
Konum
IZMIR
Sorun java kütüphanelerini açmak için belirtilen adreslerin türkçe karakter desteklemiyor oluşu.
Özetle kütüphanenin bulunduğu yere ulaşamayınca açılmıyor.

İngilizce işletim sistemlerinde bu sorun yaşanmıyor. Aslında sorun sadece Wago ya özgü de değil sanırım.

Mevcut işletim sistemini değiştirmeden ingilizce bir işletim sistemi kurmanın yolu da sanal makineden geçiyor.

Vİrtual box bir çözüm olabilir ancak müşteriye önce web browser'ı olan her bilgisayardan görebilirsin deyip sonrasında abi ingilizce olması lazımmış, sanal makine lazımmış vs vs diyince sıkıntı oluyor.
Yanlış bilgi !
Hiçbir dil türkçe karakterleri desteklemez !
+ Browser encoding UTF-8 TR_tr olduktan sonra geri kalanın bir anlamı yok...
Arkadaşın sıkıntısı UAC ayarlarının kullandığı apiye izin vermemesi yada mevcut java sürümünün artık sonlandırılmış bir uygulama sistemini kullanmış olması olabilir.
Denetim masasında java nın özelliklerinden çevirdiğininz URL için güvenilir olarak ekleyin(internet de aramak için : Java security setting). Çalışmaması durumunda java motoru mu yoksa javascript mi çalıştırdığından emin olun. Javascript ise script kaynağının geçerli olup olmadığını kontrol edin(Linklenen scripti okuma yetkiniz varmı veya o dosya orada gerçekten bulunuyor mu?).
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
slm seagate;
javanın son sürümünüde denedim olmadı.ayrıca güvenlik ayar sayfasından da plcnin ip adresi ve webvisu adresine izin vermiş durumdayım.Genede sonuç alamadım sayfa hep boş açılıyor..
 

mell

Üye
Katılım
5 Eyl 2010
Mesajlar
14
Puanları
1
Yaş
30
AHAnda çözdüm.
plcye ftp den girip orjinalinde plc_visu.xml olan dosyayı plc_vısu olarak değiştirdim.Sorun çözüldü dene bakalım bbulutlu sendeki sorunda bu muymuş..

Fikir verdiğin için teşekkürler seagate.
 

Sponsor Bağlantı

Forum istatistikleri

Konular
105,519
Mesajlar
743,172
Kullanıcılar
392,220
Son üye
Yusuf.a

Yeni konular

Üst