Siemens s7-300 özel durumları için yardım?

Katılım
15 Eki 2008
Mesajlar
41
Puanları
1
Yaş
39
merhaba s7 300 de özel durumlar varmı dicem ama çok geniş bi soru olacak =) şöyle ki, mesela örneklerde hep I 124.0 gibi kullanımlar var. bu aletin giriş çıkışlarında modül ekledikçe alfabetik sıryala çıkışları belirleyebiliyomuyuz? örneğin deltanın cpu sunda inputlarda x0-x7 ana modül girişleridir fakat yeni giriş modülü takıldığında girişleri x20-x27 kullanmak zorundayız. diğer bir örnek plc run konumuna geçince tek makine saykılı puls veren m1000 biti var.

tabiki bunları zamanlayıcılarla yapabiliriz fakat siemense yeni başladım özel durumlarını bilmiyorum =)

buna benzer özel durumları özel bitleri vardır illaki ama hiç bi kaynakta bulamadım.

yardımcı olacak uzman arkadaşlara şimdiden teşkkürlerimi sunarım =)
 
KNX Standardı, küçük bir rezidansın içerisindeki aydınlatma, perde panjur, klima kontrolünden, Dünya’nın en büyük havalimanlarındaki aydınlatma otomasyonu gibi çözümler için tercih edilen bir Dünya standardıdır.
Yazımızda endüstrinin can damarı sayılabilecek PLC’yi inceleyeceğiz.
HW config te raya eklenen her modülün üzerine tıklar ve adres kısmına bakarsın hatta istersen adresi değiştirebilirsin.
Tek makina saykılından kastını tam anlamamakla beraber eğer bir yardımcı rölenin belirli frekansla 1-0 olmasını istiyorsan bunuda HW config de CPU yu çift tıklayarak Cycle/clock memory sekmesindeki clock memory kısmına hafıza byte alanı belirterek ayarlıyorsun.
 
öncelikle teşekkürlerimi sunarım =) karıştırdım buldum.

şu anda beni deli eden bir sorunum daha var. mw100 den başaldım 4 er 4 er sırayla kullandım(mw100, mw104, mw108... ).
programd abi yerde mw104 ve mw 112ye 2016 sabit değerini yazdırıyorum. tag atamaları yapmadan önce yani yazaçlara isim koymadan önce bi sorun yoktu fakat isim koyduktan sonra paralel olarak çalıştırdığım comparatorlerin in2 sinde bulunan mw104 mw112 ve mw120 mw128 nedense kırmızı yanmaya başlıyor. ama üst tarafta sonda kullandığım yani 2016 değerini sabit girdiğim bu yazaçlarda sorun yok etiketi gayet temiz kabul etmiş.... bunun nedeni nedir anlamadım. ayrıca tekrar yazmaya kalkışınca da çakışma var etiket tablosunda diyor ama çakışma yok zaten tekler. diğer kullandığım bir sürü bit ise m0.0 dan m11.4 e kadar gidiyor... anlamadım gitti =)
 
sembol editörde ki data type değiştirmediğin için o kırmızılıklar oluyor mutemelen.WORD DWORD DINT vs.. nasıl bir comparator kullanıyorsun o da önemli.yani girişlerinde ne istiyor senden onu bilmelisin.
 
HW configuration da istediğin adreslemeyi verebilir, giriş çıkış durumlarını belirterek aynı adresleri bile verebilirsin
 
ugrastircak beni bu sanirim =) tag koymasam sorun yok. data tipini mw olarak girdigim zaman otomatik olarak word a dönüyor zaten orda bi problem yok. diger yandan hw de bakmadim ama on a da payartesi bakicam tekrar. bana dikkat ettim ve kafamda söyle bi durum olustu, eqi comparator kullaniyorum word integer yani. comparatorlerin girisindekilerde sorun var hep. rasgele programla alakasiz bi hw denedim ayni sorun sadece comparatorlerde oldu. benim comparatorlerim direk bagliydi belki dedim direk degil de arada bisi olmak zorundadir diye düsündüm "en" grisinin önüne bit koydum ama yine olmadi. dedigim gibi tagsiz olarak kullaninca sorun cikmiyor ama tag atip save der demez kizariyo bozariyo =) ilginiy icin tekrar tesekkürler..
 
HW configuration da istediğin adreslemeyi verebilir, giriş çıkış durumlarını belirterek aynı adresleri bile verebilirsin
hw config de bulamadım. sadece eklediğim io modülleri için adress analog için input ayarları var ama orda da ben secemiyorum kendisi vermiş pasif durumda gösrünüyor. yani değiştiremiyorum. ayrıca dahili word yazaçlarının yani mw lerin burda bi ayarını bulamadım... daha ayrıntılı bilgilendirirseniz sevinirim. teşekküerler
 
ugrastircak beni bu sanirim =) tag koymasam sorun yok. data tipini mw olarak girdigim zaman otomatik olarak word a dönüyor zaten orda bi problem yok. diger yandan hw de bakmadim ama on a da payartesi bakicam tekrar. bana dikkat ettim ve kafamda söyle bi durum olustu, eqi comparator kullaniyorum word integer yani. comparatorlerin girisindekilerde sorun var hep. rasgele programla alakasiz bi hw denedim ayni sorun sadece comparatorlerde oldu. benim comparatorlerim direk bagliydi belki dedim direk degil de arada bisi olmak zorundadir diye düsündüm "en" grisinin önüne bit koydum ama yine olmadi. dedigim gibi tagsiz olarak kullaninca sorun cikmiyor ama tag atip save der demez kizariyo bozariyo =) ilginiy icin tekrar tesekkürler..

tag atadığın MW otomatik WORD oluyor demişsin. orada ki WORD yazısını silip INT yaz ve save et bakalım ne oluyor ;)
 
tag atadığın MW otomatik WORD oluyor demişsin. orada ki WORD yazısını silip INT yaz ve save et bakalım ne oluyor ;)

çok güzel oluyor =) eyw... =))

vay arkadaş.... aklıma geldi ama çözüm bulamadım. cmp lerde i var d var ama w yok =) converterlere de baktım w to i diye bişey yok =)) kaldım öyle int yazılabildiğini bilmiyordum =)) çok teşekkür eder, başarılar dilerim =)
 

Forum istatistikleri

Konular
128,859
Mesajlar
921,058
Kullanıcılar
450,972
Son üye
muz35

Yeni konular

Geri
Üst