Push Pull UPS geçişinde problem

_Daisy_

Üye
Katılım
8 May 2019
Mesajlar
3
Puanları
1
Yaş
25
Merhaba,

Daha önce IPM kullanılarak tasarlanan UPS'i mosfet kullanarak push pull yöntemiyle yeniden tasarlamaya çalışıyorum. Cihazın ilk UPS geçişinde gerilim seviyesi 300V seviyelerine ulaşıyor 8-9 saniye boyunca bu seviyelerde kalıp normal seviyesine (220V) dönüyor. Bir sonraki UPS geçişlerinde herhangi bir sıkıntı yok sadece ilk geçişte bu durum gerçekleşmekte.

PWM değerlerini giriş akü gerilimini (60V) ölçerek ayarladım ve PWM değerleri (bir sonraki çalışmalarda da bir sıkıntı oluşmadığı düşünülürse) doğru değerler. Fakat neden ilk UPS geçişinde bu sıkıntıyla karşılaştığımı bir türlü anlayamadım. Bu konuda fikri olan varsa sevinirim.

Aşağıdaki resimde çıkış geriliminin yükseldiği yani sıkıntıyı yaşadığım o ilk başlangıç sinyallerinin osiloskop görüntüsü bulunmakta. 1 numaralı kanal Akü voltajındaki AC dalgalanmayı gösteriyor. 2 ve 3 numaralı kanallar push pull için PWM sinyalleri olmakta. 1 numaralı kanalda her iki kanalda kapalı olmaya başladığı andaki düşüş ve ani yükselme neden kaynaklanıyor hiç bir fikrim yok bilgisi olan varsa aydınlatırsa sevinirim.
54050


54051
 

Ekli dosyalar

serkan_48

Profesyonel Üye
Katılım
5 Ağu 2009
Mesajlar
8,062
Puanları
2,408
Yaş
38
Konum
Antalya
Cizdiginiz sema standart sema. Sorun kontrol ve fredback devresinde olmasin?
 

kesmez

Profesyonel Üye
Katılım
14 Ara 2006
Mesajlar
1,823
Puanları
283
Konum
ankara
mosfet on süreleri 5ms. 9.9ms olması gerekmiyormu.
 

_Daisy_

Üye
Katılım
8 May 2019
Mesajlar
3
Puanları
1
Yaş
25
Cizdiginiz sema standart sema. Sorun kontrol ve fredback devresinde olmasin?
mosfet on süreleri 5ms. 9.9ms olması gerekmiyormu.
Devrede feedback bulunmamakta mosfetleri ST'nin PM8834 adlı mosfet sürücüsüyle sürüyorum PWM i de bu entegreye uyguluyorum.

Daha öncede dediğim gibi PWM genişliklerini akü gerilimini sürekli olarak okuyarak güncelliyorum yazılım ile. 10msn bir mosfet için 10msn bir mosfet için şeklinde ayırdım 20msn'yi ve PWM genişlikleri 3.5 msn ile 9msn arasında değişiyor bu şekilde tek bir mosfet için. Yani hiç bir şekilde üste binme durumları da yok bir mosfetin kapatılmasıyla diğerinin açılışı arasında en az 1msn oluyor çünkü.


-------------------

Anladığım kadarıyla yüksüz durumdayken sinyalde bozulma gerçekleşiyor ups çalışıp motor devreye girdiğinde sinyaller düzgün hale geliyor. UPS'i hiç yüksüz çalıştırdığımda UPS çıkış gerilimim aşağıdaki gibi görünmekte mosfetlerin pwm'lerinin her kapatılışında ters yönde ani bir yükselme ve sonra düşüş yaşanmış.

54077

Normalde bu ani değişimlerin yaşandığı yer düz olmalı, aşağıdaki bir sinyal olmalı.


54078
Böyle bir problemle karşılaşmış olan var mıdır acaba
 

Ekli dosyalar

Son düzenleme:

Benzer konular


Sponsor Bağlantı

Forum istatistikleri

Konular
103,773
Mesajlar
729,814
Kullanıcılar
386,273
Son üye
zuco97

Yeni konular

Üst